Why can't I play AAC encoded files?

Why can't I play AAC encoded files?

Symptoms

You cannot play the AAC encoded audio tracks or videos saved on your Synology NAS.

Diagnosis

Starting from DSM 7.1.1, AAC audio codec transcoding (decoding and encoding) is no longer supported. To stream and play the files on other devices, the terminal devices (e.g., smart TVs, smartphones, tablets, and game consoles) must support native AAC decoding.

Resolution

If the terminal device does not support AAC, try the following:

  • Convert the files:
    • Covert the audio to MP3 or WAV format. You can use third-party converters, such as XMedia Recode (Windows) or Handbrake (macOS, Windows, or Linux).
    • After conversion, use File Station to re-upload the file to the music shared folder or /home/music indexed folder of Audio Station, then try playing the file again.
  • Use another player:
    • Mobile devices: Install and switch to a third-party video player, such as VLC media player.
    • Computers: If playback on web browsers fail, map or connect you Synology NAS as a network drive and use media players installed on the computer. (Instructions for macOS/Windows)
      You can use VLC media player, QuickTime (macOS), or Movies & TV (Windows 10 or above).
  • Use another media library organizer:
    • Install third-party media library organizers on your Synology NAS, such as Plex Media Server. (Supported packages)