Storage Manager shows the system partition cannot be accessed or is damaged. What can I do?

Storage Manager shows the system partition cannot be accessed or is damaged. What can I do?

Symptoms

Storage Manager shows the system partition cannot be accessed or is damaged.

Diagnosis

System partition errors may occur as a result of drive failures or other problems. You can go to Storage Manager > Overview and HDD/SSD to get more information:

  • Failed to access the system partition
    If the system partition on one or more drives become inaccessible, you will see the following status message:
    • On the Overview page, you will see the message: "Failed to access the system partition. Please repair it by clicking the following link. (Repair)"
    • On the HDD/SSD page, you will notice that the status of the drives with issues has changed to System Partition Failed.
  • System partition has crashed
    If the system partition on all your drives become inaccessible, you will see the following status message:
    • On the Overview page, you will see the message: "System partition has crashed. Please back up data and replace the damaged disks as soon as possible. Then reinstall the system with Synology Assistant."
    • On the HDD/SSD page, you will notice that the status of all the drives has changed to System Partition Failed.

Resolution

Failed to access the system partition

To repair the system partition:

  1. Launch Storage Manager.
  2. Go to Overview and click the Repair link.1
    The system should start repairing the system partition on the drives.
  3. Wait for the system to complete the repair.
  4. Go to HDD/SSD. If one or more drives still show the System Partition Failed status, they might be defective. You can do the following:
    1. Replace the defective drives one by one.
    2. Depending on what status is shown on the Overview page, repair the storage pool or the system partition.
      • For detailed instructions on repairing a storage pool, refer to the respective help articles for DSM 7 and DSM 6.2.
      • For detailed instructions on repairing the system partition refer to the respective help articles for DSM 7 and DSM 6.2.

To ensure the safety of your data and the stability of your system, we recommend regularly backing up your data and system configurations. For detailed instructions, refer to the respective help articles for DSM 7 and DSM 6.2.

System partition has crashed

To recover the system partition:

  1. Back up your data.
  2. Use Mode 2 to reset your Synology NAS and reinstall the DSM operating system.
    • If you are running DSM 6.2.4 or above, refer to this article.
    • If you are running DSM 6.2.3 or earlier, refer to this article.
  3. After the installation is complete, launch Storage Manager.
  4. Go to the HDD/SSD page and check the status of the drives. If any drives are not in a Healthy status, make sure to replace them one at a time.
  5. Depending on what status is shown on the Overview page, repair the storage pool or the system partition.
    • For detailed instructions on repairing a storage pool, refer to the respective help articles for DSM 7 and DSM 6.2.
    • For detailed instructions on repairing the system partition refer to the respective help articles for DSM 7 and DSM 6.2.

To ensure the safety of your data and the stability of your system, we recommend regularly backing up your data and system configurations. For detailed instructions, refer to the respective help articles for DSM 7 and DSM 6.2.

Notes:

  1. The Overview page will not display information about the system partition or the Repair link if there are other more urgent issues that need to be addressed. In such cases, please follow the instructions provided on the Overview page to resolve these issues first.
Symptoms
Diagnosis
Resolution
Failed to access the system partition
System partition has crashed
Further reading