How can I fix common SSL issues for Synology Drive Client, Synology Drive ShareSync, and Synology Drive mobile app?
How can I fix common SSL issues for Synology Drive Client, Synology Drive ShareSync, and Synology Drive mobile app?
Symptoms
You encounter the following SSL (Secure Sockets Layer) warnings when establishing connections or creating tasks using Synology Drive Client, Synology Drive ShareSync, or Synology Drive mobile app:
The SSL certificate of the Synology NAS is not trusted
Untrusted Connection
Diagnosis
SSL issues are related to the way you connect to the server, such as using a private IP, public IP, DDNS, etc. The following are possible causes of untrusted SSL warnings:
- The certificate of your Synology NAS was changed or had expired.
- The Synology NAS address, such as an IP address, you're using to create a task doesn't have a valid certificate.
This article provides step-by-step guides to setting up your Synology NAS properly to prevent SSL certificate issues.
Resolution
Connect to Synology NAS via a domain name
Connect to Synology NAS via QuickConnect
Connect to Synology NAS without a valid certificate
Notes:
- Port forwarding configuration methods may vary on different routers. Refer to the manual of your router or contact the manufacturer for assistance.
- Take note of the expiration date of the certificate. Always renew the certificate before it expires. Otherwise, all connections that use the certificate will be affected.
- If you use QuickConnect in LAN environment to connect to Synology Drive Server on DSM 6.2 and earlier, you might still encounter the SSL warning. In this case, manually trust the connection.
- If you use QuickConnect ID to connect to Synology Drive Server on Synology Drive mobile app and attempt to play media files, you might still encounter the SSL warning. In this case, do either of the following:
- To learn more about QuickConnect and SSL, refer to this White Paper.
Further reading
- What are some common Synology Drive Client sync or backup task issues and how can I fix them?
- What can I do when Synology Drive Client has trouble connecting to my Synology NAS?
- How to sync files between Synology NAS and your computer using Synology Drive Client
- How do I sync data between multiple Synology NAS via Synology Drive Server?
- How can I speed up the syncing process of Synology Drive?