I added new drives to my Synology NAS, but the available capacity didn't increase. What can I do?

I added new drives to my Synology NAS, but the available capacity didn't increase. What can I do?

Symptoms

You tried to expand the storage pool and volume by adding drives or replacing the original drives with larger ones. However, the available capacity did not increase.

Diagnosis

Check for the following causes:

Multiple volume support1

  1. Go to Storage Manager > Storage (DSM 7.0 and above) or Storage Pool (DSM 6.2 and below).
  2. Click the storage pool's upper-right icon 1.png to expand the information and check if the storage pool has Multiple volume support.
    • Yes: If the storage pool has multiple volume support, refer to the next section.
    • No: If the storage pool does not have multiple volume support, you can only allocate the storage pool capacity to one volume. However, if the volume has reached its maximum single volume size, you cannot increase its size.

Volume status

  1. Go to Storage Manager > Storage (DSM 7.0 and above) or Storage Pool (DSM 6.2 and below).
  2. Check the volume status.
    • If the volume is in Healthy status, you can modify the volume size. Refer to the Resolution section for detailed instructions.
    • If the volume is in Warning status because of insufficient available capacity, you can modify the volume size. Refer to the Resolution section for detailed instructions.
    • If the volume is in Warning, Critical, or other abnormal statuses because of other causes, check under the corresponding storage pool for more information. You need to resolve the volume issues first.

Notes:

  1. You do not need to check for multiple volume support if your storage pool is created in DSM 7.0 or above. Storage pools created in these DSM versions automatically come with multiple volume support.

Resolution

Do the following according to your DSM version:

For DSM 7.0 and above

  1. Go to Storage Manager > Storage.
  2. Select the volume you want to expand and click its upper-right 2.png icon.
  3. Select Settings from the drop-down menu.
  4. Go to the Modify Size section. Do either of the following:
    • Enter a new volume size in the Modify allocated size (GB) field.
    • Click the Max button if you want the volume to have all the allocatable capacity.
  5. Click Save.1

For DSM 6.2 and below

  1. Go to Storage Manager > Volume.
  2. Select the volume you want to expand.
  3. Click the Action button.
  4. Go to Configure > General. Do either of the following:
    • Enter a new volume size in the Modify allocated size (GB) field.
    • Click the Max button if you want the volume to have all the allocatable capacity.
  5. Click OK.1

Notes:

  1. Once the volume expansion is complete, you will not be able to decrease the volume size.
Symptoms
Diagnosis
Multiple volume support1
Volume status
Resolution
For DSM 7.0 and above
For DSM 6.2 and below