Virtual machine backup fails due to snapshot limit. What can I do?

Virtual machine backup fails due to snapshot limit. What can I do?

Symptom

A virtual machine failed to back up, displaying an error log "The number of virtual machine's snapshots exceeds the limit. You need to delete some snapshots on the virtual machine."

Diagnosis

Each virtual machine has a maximum snapshot limit. When this limit is reached, ActiveProtect cannot create new snapshots, resulting in backup failure.

Resolution

Check the number of snapshots on the virtual machine. If it has reached the maximum, delete unnecessary snapshots using the following steps:

VMware vSphere

  1. Sign in to the vSphere Client and navigate to the host.
  2. Right-click on the virtual machine and select Snapshots > Manage snapshots.
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  3. Check the number of snapshots on the virtual machine.
    2.png
  4. Delete some or all snapshots:
    • Select a snapshot and click Delete snapshot.
    • Click Delete all to remove all snapshots.

Microsoft Hyper-V

To check all snapshots for a virtual machine, use the following command in Windows PowerShell, replacing [VM name] with your actual virtual machine name. This will show all snapshots, including hidden ones:

Get-VM -Name [VM name] | Get-VMSnapshot
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To delete snapshots, you have two options:

  • In PowerShell, delete all snapshots with the following command, replacing [VM name] with your virtual machine name:
    Get-VM -Name [VM name] | Get-VMSnapshot | Remove-VMSnapshot
  • In Hyper-V Manager, right-click the specific snapshot you want to delete and select Delete Checkpoint.
    4.png
Symptom
Diagnosis
Resolution
VMware vSphere
Microsoft Hyper-V