Virtual machine backup fails due to the snapshot limit. What can I do?
Virtual machine backup fails due to the snapshot limit. What can I do?
Symptoms
Scenario 1
Active Backup for Business couldn't back up your virtual machine and shows the following error log:
"Virtual machine's snapshots have reached the maximum number (5). You need to delete some snapshots on the device."
Scenario 2
Active Backup for Business couldn't enable Changed Block Tracking and shows the following error log:
"Unable to enable Change Block Tracking for the device during the task. To resolve this, delete all snapshots on the virtual machine. Until then, a full backup will be performed to ensure data integrity."
Diagnosis
Each virtual machine has a maximum snapshot limit. When this limit is reached, Active Backup for Business can't create new snapshots, resulting in backup failure.
Resolution
Check the number of snapshots on the virtual machine. If it has reached the limit, delete unnecessary snapshots using the following steps:
VMware vSphere
- Sign in to the vSphere Client and navigate to the host.
- Right-click on the virtual machine and select Snapshots > Manage snapshots.
- Check the number of snapshots on the virtual machine.
- Delete some or all snapshots:
- Select a snapshot and click Delete snapshot.
- Click Delete all to remove all snapshots.
Microsoft Hyper-V
To check all snapshots for a virtual machine, use the following command in Windows PowerShell, replacing [VM name] with your actual virtual machine name. This will show all snapshots, including the hidden ones:
Get-VM -Name [VM name] | Get-VMSnapshot
To delete snapshots, you have the following options:
- In PowerShell, delete all snapshots with the following command, replacing [VM name] with your virtual machine name:
Get-VM -Name [VM name] | Get-VMSnapshot | Remove-VMSnapshot
- In Hyper-V Manager, right-click the specific snapshot you want to delete and select Delete Checkpoint.