I cannot connect to a Hyper-V server using Active Backup for Business. What can I do?

I cannot connect to a Hyper-V server using Active Backup for Business. What can I do?

Symptoms

Your Hyper-V server cannot be connected from Active Backup for Business.

Diagnosis

There might be a configuration problem. Try checking if the Hyper-V information is correct and make sure you have properly configured Windows Remote Management (WinRM).

Resolution

To check the information of the Hyper-V:

  1. Go to Active Backup for Business > Virtual Machine > Microsoft Hyper-V and click Manage Hypervisor.
  2. Select the disconnected hypervisor and click Edit.
  3. Check if the Server address, WinRM Port, Account, and Password are all correct.

To ensure WinRM is enabled and configured:

Active Backup for Business leverages the WinRM service to perform Hyper-V-related operations. By default, all currently-supported Windows operating systems are installed with WinRM. Make sure the WinRM service is enabled on the hypervisor. If it is not enabled on your device, refer to Installation and configuration for Windows Remote Management.

Notes:

  1. If you wish to use HTTPS to connect Synology NAS and Hyper-V servers, you must have a valid certificate to enable the required port (5986) for HTTPS to work. Refer to the following Microsoft articles for instructions:
  2. For Administrators group members (excluding the "Administrator" account) to configure the WinRM service, User Account Control (UAC) on Windows must be disabled when the Hyper-V server is not joined to a domain.
Symptoms
Diagnosis
Resolution
To check the information of the Hyper-V:
To ensure WinRM is enabled and configured: