Why is there file conflict on Synology Drive and what can I do?
Why is there file conflict on Synology Drive and what can I do?
Symptoms
You see duplicated files in the sync folder with the word "conflict
" and a timestamp added to the file name.
Diagnosis
If multiple computers make changes to the same file, file conflicts may occur. When this happens, Synology Drive automatically renames a conflict file to prevent data loss.
This article explains how Synology Drive handles file conflicts and how you can resolve file conflicts.
Resolution
How Synology Drive names conflict files
A conflict file is typically in this format:
<original_file_name
>_<client_name
>_<conflict_time
>_<conflict_reason
>_<conflict_number
>.<original_extension
>
An example of a conflict file is: a_Andy-PC_Jan-03-0901-2013_CaseConflict_1.txt
original_file_name
: This is the file name part of the original file. For example, "a
" is the file name part of the file "a.txt
".client_name
: This is the name used to distinguish Synology Drive clients when establishing connections. The name is different for each client.conflict_time
: This is the time the conflict occurs and is in this format: <month
>-<day
>-<hour
><minute
>-<year
>. For example, 9:01 AM January 3, 2013 will be converted intoJan-03-0901-2013
.conflict_reason
: This is the reason of the file conflict event. Currently, we have four known reasons for file conflict:WhiteSpaceConflict
: There is an extra space after a file name. For example, file "test.txt
" or folder "test
".
Solution: Simply remove the extra space.TailCharacterConflict
: There is a period after the file name. For example, file "test.
".
Solution: Simply remove the period.CaseConflict
: This occurs when you upload and sync two files of the same name. For example, files "test.txt
" and "Test.txt
" are considered the same under both Windows and macOS, even though the latter is capitalized.
Solution: Use different names from existing files/folders.TypeConflict
: This occurs when multiple files share the same name, but differ in their file types.
Solution: Use different names from existing files/folders.
conflict_number
: This is a number appended to the file name when another conflict file with the same name already exists.original_extension
: This is the extension part of the original file. For example, "txt
" is the extension part of the file "a.txt
".
Possible causes of file conflicts and corresponding solutions
- Cause: Frequently editing files in the synced folder before Synology Drive server and client have completed an initial indexing of the folder.
Solution: Put off editing files until Synology Drive has finished indexing the synced folder.1 - Cause: When multiple users are editing the same file simultaneously, especially if the editing was done directly on the server. For example, one user is editing the synced files/folders on the server via SMB while other users are editing the same files/folders via Synology Drive Client desktop applications.
Solution: If a synced file is to be edited by multiple users, please only do so from the same connection method (e.g., only via desktop applications or only on the server via SMB). - Cause: Uploading files with the same name but different file types to the synced folder.
Solution: Before uploading files, make sure no other files (of any file type) with the same name exists in the sync folder. - Cause: The sync task may be interrupted by an antivirus program during the syncing.
Solution: To prevent antivirus programs from interfering with syncing, add Synology Drive Client and the sync folder to the antivirus program's whitelist. - Cause: Multiple users are editing a file that only allows a single user to access, such as Microsoft Office documents.
Solution: Use Synology Office for sharing and editing documents among multiple users. Refer to this article for details. - Cause: Syncing unsuitable files/folders, which are files/folders that are frequently modified or can be locked by other applications (e.g., log files, databases, or folders used for backup purposes).
Solution: Make sure unsuitable files are skipped by configuring sync profiles for DSM accounts2 or editing the Sync Rule of your Synology Drive Client sync tasks3 4. - Cause: You are using other syncing programs5 to sync with the folder Synology Drive is syncing to.
Solution: Use different folders for different syncing programs.
Notes:
- You can check the sync task status in Synology Drive Admin Console > Log. When no new logs in the format "System added file XXX" show up, the synced folder status is up-to-date.
- Refer to the "Managing Sync Profiles" section of this article for details.
- You can set sync rules to skip specific files/folders in Synology Drive Client > Sync Rules > Selective Sync Settings. If there are a lot of items on the skip list, it will require more time for Synology Drive Client to recheck the list every time your computer restarts. The workaround is to create a new folder with only items you want to sync and create another sync task with the new folder.
- Refer to this article for details.
- Other syncing programs include, but are not limited to, OneDrive, Dropbox, and Cloud Sync.
- If you still encounter the file conflict issue after attempting the above resolutions, please contact Synology Technical Support for further assistance.