I cannot update virus definitions in Antivirus Essential. What should I do?
Last updated:Feb 7, 2022
I cannot update virus definitions in Antivirus Essential. What should I do?
Diagnosis
The following factors may affect the updates of virus definitions:
- The download speed of your internet connection.
- The version of the installed Antivirus Essential package.1 You can update to the latest version and try again.
Notes:
- Updating virus definitions is no longer available on Antivirus Essential 1.4.8-2801 and earlier versions because they use a previous ClamAV version as the virus scan engine. (Learn more)
Resolution
Follow the steps below to troubleshoot the issue:
- Set the DNS server value.
Go to DSM Control Panel > Network > General. Tick the Manually configure DNS server checkbox, and set the DNS server value to "8.8.8.8" or "8.8.4.4". If you are located in China, use "114.114.114.114" or "223.5.5.5" instead. If you are using other public DNS servers, set DNS server value according to the public DNS server you use. - Temporarily turn off the IPv6 setup.
Go to DSM Control Panel > Network > Network Interface > LAN > Edit > IPv6. Set IPv6 setup as Off and click OK. - Disable the MTU value configuration.1
Go to DSM Control Panel > Network > Network Interface and double-click on a LAN. At IPv4, make sure the Set MTU value manually checkbox is unticked. Click OK. - Synchronize the time with an NTP server.
Go to DSM Control Panel > Regional Options > Time > Time Setting. Select another NTP server from the Server address drop-down menu, and click Update Now. - Allow access to http://database.clamav.net.
Make sure the firewall settings on your parent router or modem allow access to http://database.clamav.net via HTTP protocol. - Update the virus definitions again.
Go to Antivirus Essential > Update, and click Update.
If the issue persists after you have tried all the methods above, please refer to this article for more information on manual virus definition update or contact Synology Technical Support for further diagnosis.
Notes:
- Certain models do not support modifying the MTU value. If the MTU value checkbox is not displayed, please skip this step.
- The update process might be affected by resource-consuming services on your Synology NAS. When the update process is taking longer than expected, you can:
- Suspend the resource-consuming services temporarily.
- Try to update virus definitions when the system is less busy.