I added new drives to my one-drive SHR, but the available capacity didn't increase. What can I do?

I added new drives to my one-drive SHR, but the available capacity didn't increase. What can I do?

Symptoms

Available capacity shows no increase after new drives are added to your SHR array.

Environment

Applicable to SHR arrays created with one drive only.

Diagnosis

Check if your SHR status is With data protection. In that case, the SHR now works the same way as RAID 1. This means that only half of the total drive capacity can be used, and the other half is dedicated for data redundancy to provide protection. If you want to utilize full capacity of the drives, follow the instructions in the next section.

Resolution

Remove the storage pool and create a new one to change the data protection status of your SHR back to Without data protection and utilize the full capacity of all drives.

  1. Make sure you back up all data on the storage pool and that there is no important data on the drives.
  2. Do the following according to your DSM version:
    • DSM 6.2 and below: Go to Storage Manager > Volume, select the volume you want to remove, and click Remove.
    • DSM 7.0 and above: Go to Storage Manager > Storage, select the volume you want to remove. Click the 1.png icon and then click Remove.
  3. Click Create and select a storage pool type.
    1. Better performance: This type of storage pool supports only a single volume but provides better performance.
    2. Higher flexibility: This type of storage pool supports multiple volumes, SHR, and the RAID Group feature.
  4. Select a RAID type and configure storage pool properties. Click Next.
  5. Select drives for the storage pool and click Next.
  6. Choose whether you want to perform a drive check and click Next.
  7. Confirm the settings and click Apply to finish.
  8. After the new storage pool is created, restore your data to the storage pool with the backup from step 1.
Symptoms
Environment
Diagnosis
Resolution
Further reading