How do I address MailPlus security log 450 4.7.25: Client host rejected?

How do I address MailPlus security log 450 4.7.25: Client host rejected?

Symptoms

In MailPlus Server > Auditing > Log, you received the following message:

450 4.7.25 Client host rejected: cannot find your hostname, [IP address]

Diagnosis

MailPlus Server rejected the SMTP connection because the hostname does not match up with the IP address in the HELO command.

Resolution

Try the following methods to troubleshoot:

  • Ask the sender to check the mapping between the hostname and IP address in DNS records.
  • Use MxToolbox to check if the mail server' IP address belongs to the sender domain.
  • Add the mail server's IP address to MailPlus Server > Mail Delivery > Security > Block/Allow List.
  • Turn off the hostname check by disabling the following option:
    • Reject unknown client hostnames in MailPlus Server > Mail Delivery > Security