I can't connect to the Internet / Wi-Fi SSID after deploying a mesh Wi-Fi system. What should I do?

I can't connect to the Internet / Wi-Fi SSID after deploying a mesh Wi-Fi system. What should I do?

Symptoms

In a Synology mesh Wi-Fi system with VLAN configured, you have trouble connecting to the Internet or some Wi-Fi SSIDs after doing one of the following:

  • After a wireless deployment, connect your Wi-Fi points to the mesh system via an Ethernet cable.
  • After a wired deployment, connect your Wi-Fi points to other Ethernet ports of the primary router.
  • Adjust any trunk port settings of your primary router.

Environment

Synology Router: SRM 1.3 or above.

Diagnosis

The connection issue occurs possibly because the Wi-Fi points are not connected to the trunk ports of your primary router (see the section Configure VLAN tags in this article for more information). The following are common scenarios:

  • Your Internet connection is not available: It is possibly because one or more Wi-Fi points are connected to the ports not belonging to the primary network.
  • You have Internet access but cannot connect to any SSIDs not belonging to the primary network: It is possibly because one or more Wi-Fi points are connected to the access ports (i.e., not a trunk port) of the primary network.

Resolution

Make sure the primary router's ports connected by Wi-Fi points belong to the primary network and are trunk ports. You can adopt the methods below to fix the issue:

Method A

When to use

  • You are unable to connect to the Internet.

Steps

  1. Unplug all your Wi-Fi points that are connected via Ethernet cables.
  2. Connect one of your Wi-Fi points to the primary router's Port 2 (i.e., the LAN 2 port). It's the trunk port assigned to the primary network by default.1.png
  3. If you want to connect the rest of your unplugged Wi-Fi points via Ethernet cables:
    1. Connect your computer to a Wi-Fi SSID that belongs to the primary network.
    2. Go to SRM Network Center > Local Network > Network.
    3. Select Primary Network and click Edit > Ethernet port.
    4. Tick the ports you want to use and save the settings.
    5. After ensuring that the specified ports are trunk ports, connect your Wi-Fi points to them.

Method B

When to use

  • Internet connection is available, but you have trouble connecting to SSIDs that do not belong to the primary network.

Steps

  1. Connect your computer to the primary router through either of the following methods:
    • Connect to Port 2 (i.e., the LAN 2 port).
    • Connect to a primary network's Wi-Fi SSID.
  2. Sign in to SRM.
  3. Go to Network Center > Local Network > Network > VLAN Tag.
  4. Click Configure VLAN Tag to view trunk ports.2.png
  5. Tick the port you wish to use and save the settings. These ports will become trunk ports when they belong to the primary network.
  6. Connect your Wi-Fi point to the specified port.

Method C

  1. Unplug your Wi-Fi points from the primary router’s Ethernet ports.
  2. Add your Wi-Fi points to the mesh Wi-Fi system using Wi-Fi signal. You can refer to this article for further instructions.
Symptoms
Environment
Diagnosis
Resolution
Method A
Method B
Method C
Further reading